We've been monitoring data usage since the last update and this has now returned to normal so we are marking this incident as resolved.
We're sorry for the disruption this caused. If you continue to experience any issues, please contact our Support Team.
Our Provider will prepare and share an RCA with us. Once we receive this, we will publish a postmortem of the incident.
Posted Jul 24, 2026 - 12:37 UTC
Monitoring
Our provider for Profiles 1 and 5 has now rolled out a potential fix. As a result, we are now seeing some impacted eSIMs connecting successfully but we expect service to resume gradually.
We will continue to monitor this closely to make sure things continue to improve and provide a further update at 12:30 UTC.
Posted Jul 24, 2026 - 11:15 UTC
Identified
Our upstream provider have identified the issue and are deploying a fix.
Posted Jul 24, 2026 - 10:12 UTC
Investigating
We've been made aware of a connectivity issue impacting Profiles 1 and 5. This has been raised to our connectivity provider and we're working with them to investigate.
We'll provide a further update as soon as possible.