Profile 1 & 5 - Connectivity issues in Costa Rica

Incident Report for eSIM Go

Resolved

After a period of monitoring, we see that usage levels have returned to normal and remained stable.
This issue is now resolved.

If you continue to experience issues, please raise them to our Support Team.
We apologise for the disruption.
Posted Jul 29, 2026 - 20:57 UTC

Monitoring

Our Profiles 1 and 5 provider has been working closely with the local network in Costa Rica to restore service.
We now see active data sessions starting to increase.
We will continue to monitor performance closely.
Posted Jul 29, 2026 - 17:36 UTC

Identified

We're looking into some connectivity issues on Costa Rica eSIMs on Profiles 1 and 5. We’re working closely with our connectivity provider to identify the cause.

While we work to get to the bottom of this, please report any issues you experience to the eSIM Go Support team.
Posted Jul 29, 2026 - 16:08 UTC
This incident affected: eSIM Connectivity.