Profile 4 (89431) Service outage

Incident Report for eSIM Go

Update

Our provider for Profile 4 (ICCIDs beginning 89431) has informed us that the issue has been identified and partially resolved. Data use has started to resume and the full resolution is expected to be deployed by 06:30 UTC. After this, we will continue to monitor the situation and provide any further updates
Posted May 28, 2026 - 02:17 UTC

Identified

Dear partners,
Our Profile 4 Provider has informed us of an issue causing a sudden loss of service across their Profile. We have been assured that this is being investigated with the highest priority and we are awaiting further updates that we will pass on as soon as they are received.
We apologise for any inconvenience caused during this time.
Posted May 28, 2026 - 01:13 UTC
This incident affects: eSIM Connectivity.