Connectivity issues for Profile 1 (ICCIDs beginning 8944)

Incident Report for eSIM Go

Resolved

After an extended period of monitoring our upstream provider continue to see data at expected levels overall. We also see recent data sessions across many of the examples which were shared with us during this incident, which we will now close.

We would like to thank you again for providing these examples and sincerely apologise for the disruption caused.
Posted Aug 01, 2025 - 03:23 UTC

Monitoring

Our upstream provider believe that data should now be restored for Profile 1 (ICCIDs beginning 8944) and see that service is already returning to expected levels overall.

Your customers shouldn't have to complete any actions from their device to restart a connection.
Posted Aug 01, 2025 - 02:08 UTC

Investigating

We’re looking into reports of connectivity issues across several destinations at the moment for Profile 1 (ICCIDs beginning 8944).

Thank you to partners who have raised examples, which have all been shared with our upstream provider.

We will post a further update when we have more to share.
Posted Aug 01, 2025 - 00:20 UTC
This incident affected: eSIM Connectivity.