Profile 2 & 3 - Unlimited bundle ordering issue

Incident Report for eSIM Go

Resolved

Dear Partners,

After an extended period of monitoring, we are observing no new issues with the ordering of unlimited bundles on Profiles 2 and 3. This has been the case since the deployment of a fix from our connectivity provider earlier today (29th October).

We sincerely apologise for the inconvenience this outage may have caused, and would encourage partners to reprocess any orders that failed during the duration of this incident. If partners encounter any further issues when trying to do so, they are encouraged to please get in contact with our support team.

Thank you for your continued patience whilst we resolved this matter with our upstream provider.

Kind regards,
eSIMGo
Posted Oct 29, 2025 - 16:44 UTC

Monitoring

A fix has been implemented and results show orders are now processing as expected. We will continue to monitor this.
Posted Oct 29, 2025 - 11:42 UTC

Investigating

We have identified an issue causing Unlimited bundle orders on Profiles 2 & 3 to fail, following our connectivity provider implementing some changes. This issue is affecting orders for UL, ULP, and ULE bundles on this Profile.

We are investigating this issue with our provider and will provide an update once we have further information.
Posted Oct 29, 2025 - 10:22 UTC
This incident affected: eSIMGo API.