Intermittent Issues accessing Portal & Help Centre
Incident Report for eSIM Go
Resolved
After extensive internal testing, we have determined that the issue is linked to a small number of DNS services outside of our control.

Reconfiguring the DNS on your local machine to use a publicly available one that is working will bypass this issue. A list of publicly available DNS can be found here at https://public-dns.info/.
Alternatively, your IT department can advise on a secure publicly available alternative that meets your policy requirements.

If you do not wish to implement the above steps, you will need to contact your Internet Service Provider and work with them to resolve the core DNS issue.

Please contact our Support Team if you have any further questions.
Posted Jul 05, 2024 - 10:20 UTC
Update
Dear partners,

Thank you for your continued patience.

We are aware some users continue to have issues connecting to our Portal. We have already identified this as an issue with one of our suppliers which is currently being tracked.

In the meantime we recommend using an alternative DNS such as https://one.one.one.one/ to allow successful connection to our Portal.

As we receive more updates we will share them with you as soon as possible.
Posted Jul 04, 2024 - 17:09 UTC
Update
Dear partners,
Our development teams continue to investigate this and get any issues fixed as soon as possible. If you are unable to reach support using the conventional ticket submission (https://help.esim-go.com/hc/en-gb/requests/new), please email support@esim-go.com.
Posted Jul 04, 2024 - 13:35 UTC
Identified
Dear partners,
We are investigating issues of intermittent issues while trying to access our Portal and our Help Centre. This is limited to a small contingency of customers but we are working to get this fixed as soon as possible.


We will be sure to provide any updates as soon as possible. Thanks for your patience while we look into this.
Posted Jul 04, 2024 - 10:26 UTC
This incident affected: Management Portal, Website, and Support Channel.