After a period of monitoring, we see that platforms are stable, both ours and our provider's. Connectivity on Profiles 2 and 3 has stabilised; please ask users to retry their connections.
A number of stuck orders from during the incident are irretrievable. We'll cancel and refund these tomorrow during business hours and provide a list of those affected.
We apologise for any disruption experienced.
Posted Aug 26, 2026 - 16:29 UTC
Monitoring
The eSIM Go platform has now stabilised. The Portal and API are now functioning as expected.
Upstream APIs have stabilised with orders and other requests completing successfully.
Connectivity looks to be gradually recovering.
We will commence a period of monitoring to ensure all services are restored to full strength.
Thank you for your patience whilst we handled this matter.
Posted Aug 26, 2026 - 15:13 UTC
Update
We believe this incident is causing some further degradation on eSIMGo's API and Portal. Some functions, for Profiles other than 2 & 3, on our API and Portal may not currently be available. We are still working to fix this as soon as possible and hope to provide a positive update soon.
Posted Aug 26, 2026 - 14:27 UTC
Update
Our provider has reported that API services are now recovering.
They report that connectivity services may also be degraded.
Our provider is continuing to work on restoring full service. We will provide further updates as we receive them.
Posted Aug 26, 2026 - 13:19 UTC
Identified
We have noticed some degradation in APIs relating to Profiles 2 and 3. Connectivity is unaffected: eSIMs already active on these Profiles are working normally.
We're still assessing the scale of this and are working with our provider to understand the cause.
Posted Aug 26, 2026 - 12:20 UTC
This incident affected: Travel API and eSIM Connectivity.