Connectivity Issues - Profile 4 (89431...)

Incident Report for eSIM Go

Monitoring

Our upstream provider for Profile 4 has identified the issue, and fixes are being put in place. End users who were experiencing problems should now be able to use 3G and 4G services again as expected. If you are still experiencing any issues, please do not hesitate to reach out to our support team. We will keep the incident open for a monitoring period to ensure all issues have been addressed.
Posted May 19, 2026 - 15:51 UTC

Identified

Our upstream provider for Profile 4 (ICCIDs beginning 89431) have identified some degraded performance with connectivity.
They are actively engaged in resolving these issues as soon as possible.
We will update once we have more information.
Posted May 19, 2026 - 13:58 UTC
This incident affects: eSIM Connectivity.