Upstream issues - Profile 2

Incident Report for eSIM Go

Resolved

After a period of monitoring, we are happy that the fix to our original SMDP+ is good.
We have now reverted back to using the original SMDP+ for newly issued eSIMs.

We apologise for the disruption caused by this.
Posted Jul 05, 2025 - 17:19 UTC

Update

The issue affecting our original SMDP+ provider has been resolved. All affected eSIMs should now connect as normal.
We will continue to issue new purchases via our backup SMDP+ until we are satisfied that the fix is effective.

Please note, the backup SMDP+ will display different a SMDP+ Address and profile statuses than our original provider.
Posted Jul 05, 2025 - 13:34 UTC

Monitoring

We have now migrated Profile 2 to use our backup SMDP+ provider.
Existing eSIMs affected by this issue should be refunded and reissued.
Any new eSIMs issued will come from the backup SMDP+ and will function as expected.

We apologise for this disruption.
Posted Jul 05, 2025 - 12:05 UTC

Identified

The root cause of the issue has been identified. There is an SMDP+ issue affecting a small number of our eSIMs.

We will be switching over to our backup SMDP+ provider until this issue is resolved.
Posted Jul 05, 2025 - 11:58 UTC

Update

We are continuing to investigate this issue.
Posted Jul 05, 2025 - 11:55 UTC

Investigating

We are currently investigating connectivity issues relating to our Profile 2 provider.
We are working with them to identify the root cause.

Affected destinations may include:
Caribbean destinations
Ethiopia
India
Japan
Jordan
Nigeria
Peru
Turkey
Posted Jul 05, 2025 - 11:44 UTC
This incident affected: eSIM Connectivity.