United States of America Connectivity Issues
Incident Report for eSIM Go
Resolved
We believe this issue is now resolved.
There is a possibility that this issue may have impacted a small number of users in Canada, although this is significantly less than the USA impact.
We will continue to monitor the situation internally. If you continue to experience issues, please reach out to our support team.
Posted Jun 26, 2024 - 19:19 UTC
Monitoring
Upstream have put a workaround in place and are reporting successful data sessions.
They are continuing investigations of the root cause and consistently monitoring traffic.
Posted Jun 26, 2024 - 18:45 UTC
Identified
Upstream have identified the issue as being with the GRX platform. They are pushing them for a resolution.
Posted Jun 26, 2024 - 17:33 UTC
Update
Our upstream provider are still investigating this issue.
We will provide updates as soon as we have them.
Posted Jun 26, 2024 - 16:48 UTC
Investigating
We are currently investigating reported issues with connectivity in the United States. We are in contact with our upstream provider and they are actively looking into this. We will provide updates as soon as we have them.
Posted Jun 26, 2024 - 13:31 UTC
This incident affected: Network.