Network outage in China

Incident Report for eSIM Go

Resolved

The network and our provider have informed us that China Mobile is operational once more.
After a period of monitoring, we believe this incident to be resolved.
We apologise for any disruption caused.
Posted Nov 25, 2025 - 08:23 UTC

Identified

Please be informed that there is an ongoing issue affecting the connection with China Mobile, which may result in slow data speeds or loss of connection. We are working closely with our upstream provider and the network to resolve the issue as soon as possible.

This outage is only affecting Profile 3 (89320) ICCIDs.
Posted Nov 24, 2025 - 16:32 UTC
This incident affected: eSIM Connectivity.