New Zealand Connectivity - Profile 1 (89444...)

Incident Report for eSIM Go

Update

The issue has been escalated with our Profile 1 Provider, and they are investigating with high priority.
Posted Jun 03, 2026 - 07:20 UTC

Investigating

We are currently investigating reports of connection issues in New Zealand.
Posted Jun 03, 2026 - 04:59 UTC
This incident affects: eSIM Connectivity.