Upstream Issues

Incident Report for eSIM Go

Resolved

After a period of monitoring, we have seen no further instances of this issue.

We apologise for this disruption.
Posted Jun 25, 2025 - 09:29 UTC

Monitoring

Upstream report that the issue is now resolved. We are seeing successful orders and service returning to normal.
We will continue monitoring the situation closely.
Posted Jun 25, 2025 - 08:27 UTC

Identified

Upstream have identified the issue and are working towards a resolution.
Posted Jun 25, 2025 - 08:08 UTC

Investigating

We are currently investigating upstream provider issues, which are currently affecting some orders and API calls
We are working with the upstream provider to resolve this as soon as possible.
Posted Jun 25, 2025 - 08:00 UTC
This incident affected: eSIMGo API.