Profile 2 & 3 (89320) - Service disruption

Incident Report for eSIM Go

Resolved

We are now observing no further errors on Profiles 2 & 3. This is following a fix that was deployed by our upstream provider. After a period of monitoring, we believe this issue is now resolved. If you encounter any further issues, please do not hesitate to get in contact with support. Thank you for your patience and understanding whilst we worked with our upstream provider to resolve this issue.
Posted Jan 16, 2026 - 13:41 UTC

Investigating

We are currently experiencing an issue with all API requests associated with Profiles 2 & 3. This has been raised as a priority to our upstream provider and we will give our partners any updates as soon as possible. This should not effect any active profile 2/3 eSIMs that are already installed on devices, or the installation of any already created eSIMs.

We thank you for our patience whilst we work to resolve this issue.
Posted Jan 16, 2026 - 09:59 UTC
This incident affected: Travel API.