After an extended period of monitoring and testing of orders and working in conjunction with our upstream provider we believe this incident is now resolved.
Thank you very much for your cooperation and patience and we're sorry for the disruption this caused.
Posted Dec 01, 2024 - 09:48 UTC
Monitoring
Our upstream provider believe they have resolved the issue which lead to the errors described in our last update.
Our tests and checks at the moment also suggest this is now resolved but we will continue to monitor and work closely with the upstream provider in the meantime.
Posted Dec 01, 2024 - 08:59 UTC
Identified
One of our upstream providers is reporting degraded performance which we believe is causing errors, including orders failing.
Examples of bundles that may currently fail are:
- United States of America - Canada - United Arab Emirates - Saudi Arabia - Turkey
This may also affect all API queries to ICCIDs beginning 89320 which are also supplied by this upstream provider.
We are working closely with the upstream provider and in the meantime ask that any calls are reduced and are made within the rate limit. We apologise for the inconvenience and thank you for your cooperation.
We will continue to share updates as we receive them.