Following re-routing the 5 destinations back to Profiles 2 and 3 (ICCID prefix 89320), a period of monitoring has shown all orders processing as expected and we will now close this incident.
Posted Jul 18, 2025 - 15:55 UTC
Update
Following a period of monitoring, orders on Profiles 2 and 3 (ICCID prefix 89320) are processing as expected.
As a result, we have rerouted Fixed bundles for the following destinations back to these profiles. - Turkey - Brazil - Japan - Kuwait - Jordan
The following countries were due to be routed to the alternate provider on July 23 2025 so Fixed bundles will stay routed to Profile 1 (ICCID prefix 89444). Unlimited bundles will move as planned on July 23 2025. New rates for these countries will be effective from July 23 2025. - South Africa - Cape Verde - Chile - Mexico
Please note, all top ups on standard or resilience profiles will still work after destinations are re-routed.
Posted Jul 18, 2025 - 13:17 UTC
Update
Our upstream connectivity provider has implemented a fix to solve the issue with processing new orders.
After a period of monitoring, we have resumed orders for Profiles 2 and 3 (ICCID prefix 89320) for all Unlimited bundles and Fixed bundle destinations that were not re-routed to an alternate provider yesterday.
We will monitor new orders to these destinations and provided orders process as expected, will start to reroute other traffic back to Profiles 2 and 3 from 11:30 UTC.
Posted Jul 18, 2025 - 09:58 UTC
Update
We continue to monitor the situation upstream and are in constant communication with our provider. Rerouting of the previously mentioned destinations is proving effective in the interim.
We will continue to provide updates as we receive them.
Thank you for your continued patience and support during this period of disruption.
Posted Jul 18, 2025 - 02:22 UTC
Monitoring
Due to the ongoing outage with one of our upstream network providers, we have rerouted the following countries’ fixed bundles from Profiles 2 and 3 (ICCID prefix 89320) to alternative resilient providers in order to resume service immediately:
Fixed bundles for: Mexico Turkey Brazil Japan Kuwait Jordan South Africa Cape Verde Chile
These changes have been completed, and new orders for fixed bundles to these destinations are now available. There are no additional charges or rate changes.
Orders for other fixed and unlimited bundles from this network provider have been temporarily suspended to prevent charges to your account.
We are working with the network supplier to resolve the issues they are experiencing and will continue to monitor the situation throughout the night. We will open orders with this provider only once we are certain that the issue has been fixed.
Any failed bundle applications will be assessed and dealt with once the issue is resolved.
We apologize for the impact this has had on you and your customers and will continue to provide updates via our Status Page as soon as we have them.
As always, we appreciate your support and partnership.
Posted Jul 17, 2025 - 23:00 UTC
Update
Our upstream provider is still looking into this with urgency. They are observing some improvement at the moment, but are still investigating the issue and the root cause.
We apologise for the continued disruption.
Posted Jul 17, 2025 - 17:37 UTC
Investigating
We're actively looking into reports of orders failing for one upstream provider and delays for calls to ICCIDs beginning 89320.
This will impact orders for the following bundles:
-Turkey -India -Caribbean destinations
Our upstream provider are looking into this with urgency.