Profile 4 (89431X) SMS Issues

Incident Report for eSIM Go

Resolved

Dear Partners,

A fix has been implemented for this issue and our SMS service on Profile 4 is now back operational. We apologise for any inconvenience caused.

If you encounter any further problems, please do not hesitate to contact our support team.
Posted May 05, 2026 - 14:55 UTC

Identified

We have identified an issue with the SMS service for Profile 4 eSIMs (ICCID: 89431X). Currently, end users may not receive any SMS you send to their eSIMs on this particular profile. No other parts of the service, or any of our other profiles, appear to be affected.

This has been raised to our upstream provider as a matter of priority, and we will provide updates as soon as possible.
Posted May 05, 2026 - 13:56 UTC
This incident affected: Travel API.