Upstream Asia Connectivity Degradation

Incident Report for eSIM Go

Resolved

After a period of monitoring, we believe the upstream issue to be resolved.
We are seeing successful data sessions in destinations that were previously impacted.

We apologise for this period of disruption.
Posted Mar 12, 2025 - 11:45 UTC

Monitoring

Upstream are reporting that the connectivity issues have been resolved.
We will continue to monitor the situation for some time.

Please advise your users to enable and disable airplane mode to force a new connection.
Posted Mar 12, 2025 - 11:08 UTC

Investigating

One of our upstream providers is currently investigating partial degradation of data services across the Asia region.
Some users may experience intermittent connectivity issues.

They are working to restore full service as soon as possible.
Posted Mar 12, 2025 - 10:37 UTC
This incident affected: eSIM Connectivity.