Czech Republic Connectivity - Profiles 1 & 5 (89444 & 89353)

Incident Report for eSIM Go

Resolved

After a period of monitoring, we are seeing continued growth in Czech Republic traffic.
We beleive that this incident is now resolved.
Please reach out to our Support Team if you have any further issues.
We apologise for the disruption.
Posted Jun 07, 2026 - 19:50 UTC

Monitoring

A fix has been implemented and is showing positive results.
We are now seeing successful usage in the Czech Republic across Profiles 1 & 5.

Please ask end users to retry their connections. Any continued issues should be reported to our Support Team.

We will continue monitoring performance.
Posted Jun 07, 2026 - 12:28 UTC

Investigating

We are continuing to investigate connectivity issues in the Czech Republic that have persisted over the last few days.
We are actively working alongside our upstream partners to resolve this disruption and restore full stability.

In the meantime, the issue may be bypassed by using the EU+ bundle from Profile 4.
Posted Jun 07, 2026 - 08:58 UTC
This incident affected: eSIM Connectivity.