Network outage in the UK

Incident Report for eSIM Go

Monitoring

Vodafone UK has implemented a fix that they believe has resolved the outage. We are seeing mobile data connectivity return to expected levels but will continue to monitor to ensure this remains the case.
Posted Oct 13, 2025 - 17:53 UTC

Identified

Vodafone UK is experiencing a major issue disrupting their 4G and 5G service.

This issue impacts mobile data connectivity on all UK eSIMs. Data only eSIMs should automatically select an alternative network, however if they don’t, you can use this article to talk your customers through manual network selection - https://help.esim-go.com/hc/en-gb/articles/11891839493649-Manual-Network-Selection

We will provide further updates as we receive them.
Posted Oct 13, 2025 - 16:19 UTC
This incident affects: eSIM Connectivity.