Temporary Reduction in 5G Coverage in the Kingdom of Saudi Arabia

Incident Report for eSIM Go

Resolved

Related to service and speed incident - updates will be shared here: https://status.esim-go.com/incidents/m427v87gfrfx
Posted Jun 25, 2025 - 09:44 UTC

Update

Our upstream provider has made 5G connectivity available again in Saudi Arabia and we expect this to resolve the connectivity issues reported by some partners.

We will keep this incident open and continue to monitor connectivity in the region. Please share any new examples you receive with our Support team in the usual way, including customer screenshots wherever possible.
Posted Jun 16, 2025 - 12:05 UTC

Monitoring

From June 14 to 15, 5G coverage in the Kingdom of Saudi Arabia will temporarily be reduced to address intermittent connectivity issues. 4G/LTE will remain full service. End users will continue to enjoy full service.
Posted Jun 13, 2025 - 16:06 UTC
This incident affected: eSIM Connectivity.