Some Failing Orders

Incident Report for eSIM Go

Resolved

After a period of monitoring, we believe that the issue is fully resolved.

We apologise for any disruption caused.
Posted Dec 06, 2025 - 20:27 UTC

Monitoring

We are aware of an issue that was causing some orders to fail.
A fix has been applied for the issue looks to have been successful.
We will continue monitoring for a period of time.

We apologise for any inconvenience caused.
Posted Dec 06, 2025 - 18:24 UTC
This incident affected: Travel Management Portal and Travel API.