Profile 1 (89444) - Multiple countries network issues

Incident Report for eSIM Go

Resolved

Following a period of monitoring, we are satisfied our Profile 1 Provider's fix has resolved this issue and this incident can now be resolved. If you encounter any further issues, please do not hesitate to get in contact with our support team.
Posted Dec 23, 2025 - 11:10 UTC

Monitoring

Our Profile 1 Provider has implemented a fix and we are observing data consumption services returning to normal. We will continue to monitor the situation.
If any ICCIDs encounter further issues of the same type, please raise this with support.
Posted Dec 08, 2025 - 23:14 UTC

Identified

Our Profile 1 Network Provider have found an issue with the online metering service for controlling data usage, and are applying a fix to restore the service.
Once this fix is deployed we will provide further updates on the monitoring of the situation.
Posted Dec 08, 2025 - 15:34 UTC

Investigating

We are currently investigating potential issues across multiple countries that is causing a degredation of service. We have escalated this, as a priority, with our provider and will report back with any updates as soon as we have them.
Posted Dec 08, 2025 - 14:58 UTC
This incident affected: eSIM Connectivity.