Cloudflare Outage

Incident Report for eSIM Go

Resolved

After a period of monitoring, we believe this incident ot be resolved.
Posted Nov 18, 2025 - 16:18 UTC

Update

Cloudflare reports that a fix has been implemented and they believe the incident is now resolved.
We are continuing to monitor from our side.
Posted Nov 18, 2025 - 15:34 UTC

Monitoring

A global Cloudflare issue has recently affected our services.

Partners may have been unable to access the Portal.
Some recent API calls may also be affected.

Data services are unaffected by this issue.

The issue looks to be resolving itself.
We are monitoring the situation and will provide further updates soon.
Posted Nov 18, 2025 - 12:12 UTC
This incident affected: Management Portal, eSIMGo API, and eSIMGo Website.