Telefonica + Movistar Connectivity Issues
Incident Report for eSIM Go
Resolved
We believe this issue is now resolved.

Our upstream providers have informed us that this issue was caused by an instability between the GRX provider and the local networks. This incident should now be resolved and connectivity should be returning as expected.

We apologise for the inconvenience this caused and will continue to monitor the situation internally. If you continue to experience issues, please reach out to our support team.
Posted Jun 28, 2024 - 09:55 UTC
Identified
Due to an upstream outage of the GRX platforms for Telefonica and Movistar, some end users may experience connectivity issues in some South American countries and Germany. This has been identified by the relevant providers and they are working to put a fix in place as soon as possible.
Posted Jun 28, 2024 - 08:17 UTC
This incident affected: Network.