Following a period of monitoring, we are now satisfied the fix implemented by our upstream provider has been effective in restoring the service in Germany. Thank you for your patience whilst we investigated and resolved this matter.
If you encounter any further issues, please do not hesitate to contact our support team.
Posted Jul 29, 2026 - 16:11 UTC
Monitoring
Our connectivity provider found configuration issue that they believe has been causing the connectivity issues seen on some Germany eSIMs They've implemented a fix at 1pm UTC today.
We will continue to monitor connectivity in Germany to make sure the fix has resolved this incident. In the meantime, please continue to raise any examples of connectivity issues you see. Thank you for your continued patience while we investigate this.
Posted Jul 28, 2026 - 15:15 UTC
Identified
We're aware of some connectivity issues in Germany on Profile 5 eSIMs - not all eSIMs are impacted.
While we work with our connectivity provider to get to the bottom of this, please report any issues you experience to the eSIM Go Support team.