Profile 4 (89431...) intermittent connectivity issues

Incident Report for eSIM Go

Resolved

Our Profile 4 provider has informed us that the issue causing intermittent connectivity has been resolved and services should return to normal.
We will continue to monitor for the next hour to ensure this is resolved and provide further updates at 15:00 UTC.

EDIT at 15:04 UTC:
After a period of monitoring, we are seeing no further issues so have resolved this incident.
Posted Jul 03, 2026 - 14:09 UTC

Investigating

We're seeing intermittent connectivity issues on network Profile 4.
Our provider for Profile 4 is already aware and looking into the cause of this.

Destinations/bundles covered by Profile 4 can be found by checking your latest rate sheet.

We will continue to work closely with them to resolve this and provide a further update as soon as possible.
Posted Jul 03, 2026 - 13:53 UTC
This incident affected: eSIM Connectivity.