Profile 1 & 5 Data service degradation

Incident Report for eSIM Go

Identified

Our profile 1 & 5 provider has identified the issue and are making steps towards a resolution.
This outage is affecting all data services across these profiles and is not localised to a single region.

We will provide further updates on the status of the resolution as soon as they are available to us.
Posted Aug 13, 2026 - 21:03 UTC

Investigating

Our Profiles 1 and 5 provider has informed us of a major outage affecting all data services across some regions. The exact nature and scope of this are being investigated and reviewed.
We will provide any further updates on expected recovery times and the exact affected regions as soon as we have this information.
While we are investigating, please raise any reports to our support team.
Posted Aug 13, 2026 - 19:40 UTC
This incident affects: eSIM Connectivity.